Nuke Lens Distortion Removal Plugin
  • c_plus
  • Nuke Lens Distortion Removal Plugin by Matti Gruener

An archive which contains source code and pre-compiled binaries (Linux, Mac OS X and MS Windows) of a 3DEqualizer lens distortion removal plugin for The Foundry's Nuke compositing software.


The new version of our lensdist3denuke-plugin now supports the fileformat that is exported by 3DE4s python script "Export WarpD4" (v1.1) and lets you use animated distortion data for your scripts in The Foundry's Nuke. For support of the old warpd format please use the first version of the plugin since that data isn't supported anymore either by 3DE4 nor by this plugin. You'll find precompiled binaries for Linux and Windows in the repository that were created using the library provided with Nuke 6. We'll provide a compiled .dylib for Mac-users shortly. 

Application: As before you can set all the data manually or browse for a file ( *.warp4 ) to read the data from there. You'll have to set the startframe manually if you want your animated distortion starting at any other frame than the preset. Please note that the resolution of your input file has to be the same as that of the plate you used in 3DE4 since the resolution is read from the warp4-file and can not be changed in Nuke. 

For feedback, bug-reports or support please write to the author of the plugin, Matti Gruener who developed this open-source tool as member of the /* Jupiter Jazz */ group in April 2010.

Please save your recent changes.
You Forgot to Accept the License Agreement
Please accept the Software License Agreement in order to proceed with your download.
Your script has been rejected! Please fix all issues listed below before uploading again. Thanks!